Κεφάλαιο 2.2. Ενδεικτικές απαντήσεις των Ερωτήσεων – Θεμάτων προς συζήτηση – Δραστηριοτήτων

Στο αρχείο (3η έκδοση), υπάρχουν ενδεικτικές απαντήσεις των Ερωτήσεων – Θεμάτων προς συζήτηση – Δραστηριοτήτων του Κεφαλαίου 2.2.

Advertisements
This entry was posted in ΑΕΠΥ, Ενότητα 2 and tagged , . Bookmark the permalink.

2 Responses to Κεφάλαιο 2.2. Ενδεικτικές απαντήσεις των Ερωτήσεων – Θεμάτων προς συζήτηση – Δραστηριοτήτων

  1. Κική Λυμπεροπούλου says:

    Σας στέλνω κάποιες μικρές πιθανές διορθώσεις σε κάποια σημεία (χωρίς χρήση Υποπρογράμματος στην 45). Ενημερώστε με αν συμφωνείτε ή όχι. Ευχαριστώ
    15B. i, ii, iv (όχι iii)

    25. Ανάποδα τα 1,5 και 1,8
    Αλγόριθμος Τράπεζα
    Διάβασε ΠΚ
    Αν ΠΚ=12 τότε
    Εμφάνισε x
    Τέλος_αν
    Τέλος_επανάληψης
    Τέλος Ψηφία

    32.Δεν αναφέρει στην εκφώνηση ότι θα διαβάζει μέχρι 20 γράμματα
    Αλγόριθμος Άλφα
    κ← 0
    ν← 0
    Όσο κ<3 επανάλαβε
    Αρχή_επανάληψης
    Διάβασε χ
    ν← ν+1
    Μέχρις_ότου χ="Α"
    κ← κ +1
    Τέλος_επανάληψης
    Εμφάνισε ν
    Τέλος Άλφα

    41. Επίλυση χωρίς τη χρήση νέου πίνακα
    Αλγόριθμος Αναζήτηση
    Διάβασε N
    Για i από 1 μέχρι N
    Διάβασε A[i]
    Τέλος_επανάληψης
    Εμφάνισε "Αναζητούμενο σχολείο:"
    Διάβασε Κ
    Βρέθηκε ← Ψευδής
    Θέση ← 0
    Για i από 1 μέχρι N
    Αν Κ = A[i] τότε
    Θέση ← i
    Εμφάνισε Θέση
    Βρέθηκε ← Αληθής
    Τέλος_αν
    Τέλος_επανάληψης
    Εμφάνισε Βρέθηκε
    Τέλος Αναζήτηση

    45. Η Δομή Για από 1 μέχρι 1000
    Αλγόριθμος Αναζήτηση
    ΠΛ ← 0
    Για i από 1 μέχρι 1000
    Διάβασε A[i]
    Τέλος_επανάληψης
    Διάβασε Κ
    Για i από 1 μέχρι 1000
    Αν Κ = A[i] τότε
    ΠΛ← ΠΛ+1
    Τέλος_αν
    Τέλος_επανάληψης
    Εμφάνισε ΠΛ
    Τέλος Αναζήτηση

    Like

    • sdoukakis says:

      Ευχαριστούμε! Έγιναν οι σχετικές διορθώσεις.
      Στην 25 δεν υπάρχει πρόβλημα.
      Ευχαριστούμε για τις προτάσεις στην 41 και 45.
      Στη 41 είναι χρήσιμο να επιστραφεί και ο πίνακας με τις θέσεις.

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s